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Objectives 

1. To Setup database management system DBMS 

2. Access DBMS with Command and GUI 

3. Create your first database 

Equipment/software 

1. XAMPP Apache + MariaDB + PHP 

2. Netbeans 

Introduction 

What a Database? A brief definition might be to store information, held over a period time and in 

computer readable form. A Store of Information classified into some practical purpose: (a) Static: 

Information collected for the sake of making a statistical analysis, e.g. the national census, or a survey of 

cracks in a stretch of motorway; (b) Growing: Textual material required for information retrieval e.g. 

technical abstracts, statutory or other regulations; (c) Dynamic: Operational and administrative 

information required for running an organization. In a commercial concern this will take the form of stock 

records, personnel records, customer records, among others. 

Held period of time define census information is collected on a particular date and stored as a 

snapshot of the state of affairs when the survey was taken. Information from later observations will be 

kept quite separately, but appropriate comparisons may be made provided that the framework remains 

consistent. Bibliographic or other textual databases are accumulated over time - new material is added 

periodically but probably very little will be removed. When designing such a database it will be important 

to estimate and allow for the expected rate of growth, and perhaps to ensure that the more recent 

information is given some priority. An organizational database may not change very drastically in size, but 

it will be subject to frequent updating (deletions, amendments, insertions) following relevant actions 

within the organization itself. 

In Computer Readable Form, computer storage and processing implies the use of software: in the 

current context a Database Management System (DBMS). The function of the DBMS is to store and 

retrieve information as required by applications programs or users sitting at terminals, using the facilities 

provided by the computer operating system. It is one of a number of software layers making computer 

facilities available to users with perhaps comparatively little technical expertise. 

Summary of DBMS Functions 

Data Definition is including the files, record structures, (field names, types and sizes), 

relationships between records of different types and extra information to make searching.  

Data Entry and Validation may include type checking, range checking and consistency checking. 

Updating involves record of insertion, modification and deletion. Data retrieval on the basis of selection 

criteria by provide “Query” with which the characteristics of the required records may be specified and 

these allowed the selection of records on the basis of particular field values, selection of particular fields 

from records to be displayed and linking together records from two different files on the basis of matching 

field values. Report Definition provide facilities for describing how summary reports from the database 

are to be created and laid out on paper and may include (counts, totals, averages, maximum and minimum 

values). Security has several aspects which ensuring that only those authorized to do so can see and 



modify the data, generally by some extension of the password principle. Secondly, security ensured the 

consistency of the database where many users are accessing and up-dating it simultaneously. Third, 

security ensured the existence and INTEGRITY of the database after hardware or software failure. At the 

very least this involves making provision for back-up and re-loading. 

Software Installation and Configuration 

XAMPP 

XAMPP is the title used for a compilation of free software. The name is an acronym, with each 

letter representing one of the five key components. The software packet contains the web server Apache, 

the relational database management system MySQL (or MariaDB), and the scripting languages Perl and 

PHP. The initial X stands for the operating systems that it works with: Linux, Windows, and Mac OS X. 

Apache: ihe open source web server Apache is the most widely used server worldwide for delivery 

of web content. The server application is made available as a free software by the Apache Software 

Foundation. 

MySQL/MariaDB: in MySQL, XAMPP contains one of the most popular relational database 

management systems in the world. In combination with the web server Apache and the scripting language 

PHP, MySQL offers data storage for web services. Current XAMPP versions have replaced MySQL with 

MariaDB (a community-developed fork of the MySQL project, made by the original developers). 

PHP: the server-side programming language PHP enables users to create dynamic websites or 

applications. PHP can be installed on all platforms and supports a number of diverse database systems. 

Perl: the scripting language Perl is used in system administration, web development, and network 

programming. Like PHP, Perl also enables users to program dynamic web applications. 

Alongside these core components, this free-to-use Apache distribution contains some other 

useful tools, which vary depending on your operating system. These tools include the mail server Mercury, 

the database administration tool phpMyAdmin, the web analytics software solutions Webalizer, OpenSSL, 

and Apache Tomcat, and the FTP servers FileZilla or ProFTPd.AMPP 

Installing XAMPP 

If you’re using Linux or Mac OS X, then the steps listed below for the installation process may 

differ. 

Step 1: Download 

XAMPP is a release made available by the non-profit project Apache Friends. Versions with PHP 

5.5, 5.6, or 7 are available for download on the Apache Friends website. 

Step 2: Run .exe file 

Once the software bundle has been downloaded, you can start the installation by double clicking 

on the file with the ending .exe. 

Step 3: Deactivate any antivirus software 

Since an active antivirus program can negatively affect the installation process, it’s recommended 

to temporarily pause any antivirus software until all XAMPP components have successfully been installed. 



 

Before installing XAMPP, it is advisable to disable the anti-virus program temporarily 

Step 4: Deactivate UAC 

User Account Control (UAC) can interfere with the XAMPP installation because it limits writing 

access to the C: drive, so we recommend you deactivate this too for the duration of the installation 

process. To find out how to turn off your UAC, head to the Microsoft Windows support pages. 

 

User account control can affect the installation of XAMPP 

Step 5: Start the setup wizard 

After you’ve opened the .exe file (after deactivating your antivirus program(s) and taken note of 

the User Account Control, the start screen of the XAMPP setup wizard should appear automatically. Click 

on ‘Next’ to configure the installation settings. 

 

You can start the setup on the startup screen 

 

https://www.ionos.com/digitalguide/fileadmin/DigitalGuide/Screenshots/XAMPP_01.jpg
https://www.ionos.com/digitalguide/fileadmin/DigitalGuide/Screenshots/XAMPP_02.jpg
https://www.ionos.com/digitalguide/fileadmin/DigitalGuide/Screenshots/XAMPP_03.jpg


Step 6: Choose software components  

Under ‘Select Components’, you have the option to exclude individual components of the XAMPP 

software bundle from the installation. But for a full local test server, we recommend you install using the 

standard setup and all available components. After making your choice, click ‘Next’. 

 

In the dialog window entitled 'select components', you can choose the software components 

before installation 

Step 7: Choose the installation directory  

In this next step, you have the chance to choose where you’d like the XAMPP software packet to 

be installed. If you opt for the standard setup, then a folder with the name XAMPP will be created under 

C:\ for you. After you’ve chosen a location, click ‘Next’. 

 

https://www.ionos.com/digitalguide/fileadmin/DigitalGuide/Screenshots/XAMPP_04.jpg
https://www.ionos.com/digitalguide/fileadmin/DigitalGuide/Screenshots/XAMPP_05.jpg


For the next step, you need to select the directory where XAMPP should be installed 

Step 8: Start the installation process  

Once all the aforementioned preferences have been decided, click to start the installation. The 

setup wizard will unpack and install the selected components and save them to the designated directory. 

This process can take several minutes in total. You can follow the progress of this installation by keeping 

an eye on the green loading bar in the middle of the screen. 

 

According to the default settings, the selected software components are unpacked and installed 

in the target folder 

Step 9: Windows Firewall blocking 

Your Firewall may interrupt the installation process to block the some components of the XAMPP. 

Use the corresponding check box to enable communication between the Apache server and your private 

network or work network. Remember that making your XAMPP server available for public networks isn’t 

recommended.  

Step 10: Complete installation 

Once all the components are unpacked and installed, you can close the setup wizard by clicking 

on ‘Finish’. Click to tick the corresponding check box and open the XAMPP Control Panel once the 

installation process is finished. 

https://www.ionos.com/digitalguide/fileadmin/DigitalGuide/Screenshots/XAMPP_06.jpg


 

By clicking on 'finish', the XAMPP Setup Wizard is completed 

The XAMPP Control Panel 

Controls for the individual components of your test server can be reached through the XAMPP 

Control Panel. The clear user interface logs all actions and allows you to start or stop individual modules 

with a single. The XAMPP Control Panel also offers you various other buttons, including: 

• Config: allows you to configure the XAMPP as well as the individual components 

• Netstat: shows all running processes on the local computer 

• Shell: opens a UNIX shell 

• Explorer: opens the XAMPP folder in Windows Explorer 

• Services: shows all services currently running in the background 

• Help: offers links to user forums 

• Quit: closes the XAMPP Control Panel 

 

In the Control Panel, you can start and stop individual modules 

Starting modules 

https://www.ionos.com/digitalguide/server/tools/introduction-to-netstat/
https://www.ionos.com/digitalguide/fileadmin/DigitalGuide/Screenshots/XAMPP_08.jpg
https://www.ionos.com/digitalguide/fileadmin/DigitalGuide/Screenshots/EN_XAMPP_Control_Panel_1.PNG


Individual modules can be started or stopped on the XAMPP Control Panel through the 

corresponding buttons under ‘Actions’. You can see which modules have been started because their 

names are highlighted green under the ‘Module’ title. 

 

An active module is marked in green in the Control Panel 

If a module can’t be started as a result of an error, you’ll be informed of this straight away in red 

font. A detailed error report can help you identify the cause of the issue.  

Netbeans 

NetBeans is an open-source integrated development environment (IDE) for developing with Java, 

PHP, C++, and other programming languages. NetBeans is also referred to as a platform of modular 

components used for developing Java desktop applications. 

These instructions describe how to download and install NetBeans, a commonly used 

IDE for Java programming. Using an IDE means that you have all of the tools you need in one 

place (your "development environment") instead of having to organize things manually. 

Step 0: Install JDK 

To use NetBeans for Java programming, you need to first install Java Development Kit (JDK). See 

"JDK - How to Install ". 

Step 1: Download 

Download "NetBeans IDE" installer from http://netbeans.org/downloads/index.html . There 

are many "bundles" available. For beginners, choose the 1st entry "Java SE" (e.g., "netbeans-8.2-

javase-windows.exe " 95MB). 

Step 2: Run the Installer 

Run the downloaded installer. 

http://web.archive.org/web/20190415195331/http:/www3.ntu.edu.sg/home/ehchua/programming/howto/JDK_HowTo.html
http://web.archive.org/web/20190415195331/http:/netbeans.org/downloads/index.html
https://www.ionos.com/digitalguide/fileadmin/DigitalGuide/Screenshots/EN_XAMPP_Control_Panel_2.PNG


Example  

To start PHP development in the NetBeans IDE for PHP, you first need to create a project. A project 

contains the information on the location of the project files and the way you want to run and debug your 

application (run configuration).  

Start the IDE, switch to the Projects window, and choose File > New Project. The Choose Project 

panel opens. 

In the Categories list, choose PHP. 

In the Projects area, choose PHP Application and click Next. The New PHP Project > Name and 

Location panel opens. 

 

Figure 1. Name and Location panel of New PHP Project wizard, with Source Folder location as 

XAmpp document root. 

1. In the Project Name text field, enter NewPHPProject . 

2. In the Sources Folder field, browse for your PHP document root and create a subfolder 

there called NewPHPProject . The document root is the folder where the web server looks 

for files to open in the browser. The document root is specified in the web 

server configuration file. For example, on Xampp, the document root is 

XAMPP_HOME/htdocs. 

3. Leave all other fields with their default values. Click Next. The Run Configuration window 

opens. 

https://netbeans.apache.org/kb/docs/php/index.html#configuration


 

1. In the Run As drop-down list, select Local Web Site. The project will run on your local 

Apache server. Your other options are to run the project remotely via FTP and to run it 

from the command line. 

2. Leave the Project URL at default. 

3. Click Finish. The IDE creates the project. 

Running Your First PHP Project  

1. Start the IDE, choose File > Open Project. The Open Project dialog box opens. 

2. Select NewPHPProject and click Open Project. The NewPHPProject tree appears in the 

Projects window and the project’s index.php file opens in the editor and in the Navigator 

window. 

 

 

 



1. Enter the following code inside the <?php ?> block: 

 

 

1. To run the project, position the cursor on the NewPHPProject node and choose Run from 

the context menu. The figure below shows what you should see in the browser window: 

 

Create PHP Project 

Start the IDE in case it's not running. Now click the File Options on Main Menu -> New Project. It 

will show the New Project Wizard as shown in Fig 1.1 

 
Fig 1.1 

Select PHP from the Categories option and also select PHP Application from Projects 

option as highlighted in Fig 1.1. The NetBeans 11 will show a message in the description section to enable 

appropriate plugins required for PHP development, in case it's the first project. Now click the Next 

Button. On the next wizard, NetBeans will find the corresponding plugins required for PHP development 

as shown in Fig 1.2 and shows the project configuration options as shown in Fig 1.3. 



 
Fig 1.2 

 
Fig 1.3 

You can choose the appropriate location of the project and PHP version depending on your project 

needs. 

Provide the project name and location based on your requirements and also select the PHP 

version. I have selected PHP 7.4 since it's already installed on my system. You can follow How To Install 

PHP 7 On Windows to install the most recent version of PHP. You can also install PHP bundled 

with XAMPP or WAMP by following How To Install XAMPP On Windows or How To Install 

WampServer on Windows. Now click on the Next Button. The next wizard provides options to choose 

the project's runtime configurations. I have selected Script for this tutorial as shown in Fig 1.4. 

https://php.tutorials24x7.com/blog/how-to-install-php-7-on-windows
https://php.tutorials24x7.com/blog/how-to-install-php-7-on-windows
https://php.tutorials24x7.com/blog/how-to-install-xampp-on-windows
https://php.tutorials24x7.com/blog/how-to-install-wampserver-on-windows
https://php.tutorials24x7.com/blog/how-to-install-wampserver-on-windows


 
Fig 1.4 

It also asks for the corresponding PHP Interpreter to execute the program for the Script Option. 

The configuration should be similar to the one as shown in Fig 1.5 and Fig 1.6. 

 
Fig 1.5 

Click the Apply Button to apply the PHP Interpreter configurations. 



 
Fig 1.6 

Apart from Script Option to run PHP program on the console, there are few more options specific 

to Runtime including Local Web Site, Remote Web Site, and PHP Built-in Web Server. This tutorial does 

not discuss the additional Runtime configuration. After selecting the Script as a Runtime option, we can 

also select the location where PHP is installed. 

Now click the Next Button. The next screen provides options to configure the PHP Frameworks 

as shown in Fig 1.7. 

 
Fig 1.7 

Now click the Next Button. The next wizard provide options to configure Composer as shown in 

Fig 1.8. We will simply skip this step since we will be writing a simple Hello World program in this tutorial. 



 
Fig 1.8 

Now click the Finish Button to complete the project set up. The project with 

default index.php file created by NetBeans looks like the one shown in Fig 1.9. 

 
Fig 1.9 

Hello PHP 

In this step, we will update the index.php program and execute it on the console. Write Hello PHP 

as shown below. 

<?php 

echo "Hello PHP !!"; 

 

Now right-click on the index.php file in the Projects Window on the left panel. Also, click 

on Run to execute the program as shown in Fig 10. You can also select the File on Projects Window 

and press Shift + F6 to execute the program. 



 

Fig 1.10 
It will show the output as shown in Fig 1.11. 

 

Fig 1.11 
These are the basic steps required to write and execute PHP programs using NetBeans 11. 

Summary 

This example explained the steps required to create the first PHP project using NetBeans 11 and 

also explained to write and execute the PHP programs. 

 

 


